Resolved
Delayed Naira payouts

Started
May 26, 2022 at 6:10 PM
Status
Resolved after about 1 hour

Impact

Operational
Affected
Payouts
Nigerian Naira
  • Resolved
    May 26, 2022 at 7:24 PM

    We just resolved the issue! Payouts should be back to standard processing schedule

  • Monitoring
    May 26, 2022 at 7:23 PM

    A fix was recently implemented and has been deployed to production. We are monitoring the status of this and will post any new update if necessary!

  • Investigating
    May 26, 2022 at 6:10 PM

    We are currently investigating this incident.