Resolved
Delayed Naira payouts

Started
May 28, 2022 at 12:46 PM
Status
Resolved after about 12 hours

Impact

Operational
Affected
Payouts
Nigerian Naira
  • Resolved
    May 29, 2022 at 12:19 AM

    We just resolved the issue! Payouts are now back to a 100%

  • Monitoring
    May 28, 2022 at 3:51 PM

    We are currently monitoring Naira payouts as they seem to be recovering. Please keep an eye out for updates!

  • Investigating
    May 28, 2022 at 12:46 PM

    We are currently investigating this incident