Resolved
Delayed Payouts to Nigerian banks

Started
July 01, 2022 at 9:35 PM
Status
Resolved after about 9 hours

Impact

Operational
Affected
Payouts
Nigerian Naira
  • Resolved
    July 02, 2022 at 6:57 AM

    We just resolved the issue!

  • Investigating
    July 01, 2022 at 9:35 PM

    We are currently investigating this incident. Your payouts to your local Nigerian bank account would take longer than expected