Resolved
NIBSS: Delayed payouts to local bank accounts in Nigeria

Started
July 06, 2022 at 9:22 PM
Status
Resolved after about 7 hours

Impact

Operational
Affected
Payouts
Nigerian Naira
  • Identified
    July 06, 2022 at 9:22 PM

    We are continuing to work with our providers to resolve this

  • Resolved
    July 06, 2022 at 2:51 PM

    We just resolved the issue!