Resolved
Delayed payouts to some Nigerian banks

Started
July 28, 2022 at 5:13 PM
Status
Resolved after 1 day

Impact

Operational
Affected
Payouts
Nigerian Naira
  • Resolved
    July 29, 2022 at 5:48 PM

    We just resolved the issue!

  • Identified
    July 29, 2022 at 11:07 AM

    Payouts are still being delayed across a bunch of banks. We are working to resolve this. Please reach out to support@fluidcoins.com if there are any issues or questions

  • Investigating
    July 28, 2022 at 5:13 PM

    We are seeing payments to some banks like Access and GTB take longer than expected. We'd keep posting updates as they come through