Resolved
Delayed Naira payouts

Started
August 31, 2022 at 8:56 PM
Status
Resolved after about 14 hours

Impact

Operational
Affected
Payouts
Nigerian Naira
  • Resolved
    September 01, 2022 at 10:52 AM

    We just resolved the issue!

  • Monitoring
    September 01, 2022 at 9:04 AM

    This seems to have recovered but a few transfers are still yet to go out

  • Identified
    September 01, 2022 at 2:34 AM

    The delayed payout is from the settlement bank (NIBSS). We are monitoring the progress regardless

  • Investigating
    August 31, 2022 at 8:56 PM

    We are currently investigating this incident. and can suggest holding off making transfers to Access bank, GTB, zENITH bank and Union bank